Discussions By Condition: Urinary conditions

Very high WBC in urine, blood, no bacteria? No symptoms.

Posted In: Urinary conditions 2 Replies
  • Posted By: RachelBullets
  • January 20, 2009
  • 10:40 PM

This is the second urinalysis that has shown visible pus in my urine, and occasionally blood, but no bacteria from either culture. My doc performed a culture because there were no nitrites in my urine. In July, I fount out that I had a kidney infection, and was put on Cipro to clear it up. The only signs of anything bad that I have had is very cloudy, bloody, or dicolored urine. I've had no pain or burning, besides in my back. Any ideas?

Reply Flag this Discussion

2 Replies:

  • Stop using wi-fi. and stay away from all wi-fi antennas.
    Anonymous 42,789 Replies Flag this Response
  • I'm hardly ever around wi-fi and live in a fairly rural town, so they're not everywhere. There's been other concerning, serious symptoms and bleeding, for 2 years, and development of symptoms continues.
    RachelBullets 120 Replies Flag this Response
Thanks! A moderator will review your post and it will be live within the next 24 hours.

Signs of a Psoriasis Flare

Know the five types of psoriasis and how to spot flares.

How Diabetes Medications Affect Your Appetite

Newer diabetes treatments can suppress appetite and aid weight loss.

What to Do For Dry Mouth

Try these tips to get your salivary glands back into action.

The Painkiller – Constipation Connection

Constipation is a common side effect of opioid and narcotic pain medicines.

9 Signs of Sensitive Skin

Is it sensitive skin or something else?