Discussions By Condition: Urinary conditions

Pyuria with no bacteria

Posted In: Urinary conditions 1 Replies
  • Posted By: Anonymous
  • August 27, 2006
  • 06:09 AM

I guess I'm not the only one with pee problems. I am a 50yr female with Addison's Disease. I have >250 WBC's per field in my urine but no bacteria. I'm a Medical Technologist so I have access to testing equipment. I work 3rd shift, and I test my urine upon rising, and there always 2+ protein (not backed up by salicylic acid test) along with 1+ RBC's. When I get to work, I test it again along with a microscopic. There is no protein then (23:00 approx is when I arrive) and trace RBC's. I have nausea along with no appetite, loose stools, and periods of dizziness. I do not have any backache or sideaches. I did have a 100.4 fever but that was several weeks ago. I have had a renal ultrasound, but it is taking forever to get the results. Oh, and my TB skin test from 30 days ago was negative. Please. please..does anyone have any idea what could be the problem?? I have no actual pain when I urinate, but it doesn't feel completely normal either. My urine is not discolored nor do I have difficulty in urinating. I drink water, cranberry and blueberry juices. No soda, no beer, no milk. I keep coming back to renal TB, but my skin test was neg. Any help would be greatly appreciated!

Reply Flag this Discussion

1 Replies:

Thanks! A moderator will review your post and it will be live within the next 24 hours.

Signs of a Psoriasis Flare

Know the five types of psoriasis and how to spot flares.

How Diabetes Medications Affect Your Appetite

Newer diabetes treatments can suppress appetite and aid weight loss.

What to Do For Dry Mouth

Try these tips to get your salivary glands back into action.

The Painkiller – Constipation Connection

Constipation is a common side effect of opioid and narcotic pain medicines.

9 Signs of Sensitive Skin

Is it sensitive skin or something else?