Discussions By Condition: Urinary conditions

antibiotics for 4 days, no improvement

Posted In: Urinary conditions 0 Replies
  • Posted By: raymae
  • August 24, 2008
  • 07:29 PM

hi everyone
on tuesday last week i started having problems below. it felt like a tingly throbbing feeling (didnt hurt but very irritating) then by wednesday i started needing the toilet quite a lot and my urine was very strong smelling. well i see my gp thursday and on her test in the office she said that the result was borderline so gave me trimethoprim to take (20ml twice a day) and said she will send sample to lab , of which i have got to phone for results.
since i have been taking it i dont really see any improvment. i thought that things were finally settling on day 3 of treatment but today (day 4) the problem seems to be worse. i drank lots of cranberry juice yesterday, could this of aggrivated it? i was under the belief that its good for uti???
i have no pain on urination and only occcassional mild pain around pubic bone area. i still have the pulsating feeling at times and strong smelling urine, also about once a day there is a very minute dot of blood when i wipe. i also have a bit of a sting feeling sometimes inside the vagina???
when i go to toilet (which is quite often at the moment) i rarely do a full wee, mostly just little bits and still feel as if i need to do more and more.
i read that if antibiotics dont clear in the first 3 days then they have not worked. im back to doctors tuesday for results and to see dr again.
any replies will be much appreciated.

Reply Flag this Discussion
Thanks! A moderator will review your post and it will be live within the next 24 hours.