Discussions By Condition: I cannot get a diagnosis.

Redness/pain on tip of penis + other symptoms

Posted In: I cannot get a diagnosis. 1 Replies
  • Posted By: mikey5559900
  • February 19, 2011
  • 05:15 AM

32 yr old male - exposure to unprotected sex, pain during intercourse caused by girlfriends loose IUD (has been removed), 2 weeks in baja mexico (food buffets,swimming in the ocean, dirty towels, sex in public hot tub where some water may have been shot inside the penis), took amoxacillin and difrucam for respiratory infection. Symptoms began a couple weeks after.


Pain (pinching) started as mild, quickly became severe in a few days. Redness and irritation on the tip. Very uncomfortable to rub against clothing. Too painful to attempt sex. Urination only slightly painful.
Urgent care diagnosis after 1 week: urethritis - treated with doxycycline and cipro for 10 days. std screen for gonorrhea and trich came back negative.



Improved slightly, may just be due to time passing. Still active with cycles of good and bad days. Veins popping out abnormally, especially after erection. Possible very small white bumps on the shaft, doctor said those are normal but they didn't seem to be there before.

Urology appt (2 weeks): negative for bacteria. no diagnosis. See if condition improves and return in 6 weeks.


Very slight improvement on pain and irritation. Slight white/clear discharge. Penis lips appear sometimes stuck together, sometimes swollen and open like the lips on a mouth. Skin where head meets shaft is very sticky. Some discoloration. Dull pain in area between genitals and anus and both sides of lower abdomen.


General practice doc (5 weeks) diagnosis: opportunistic fungal infection. Nystatin cream for 2 weeks. No effect.


Condition persists with days of only slight pain alternating with days where it's very inflamed. Made worse by movement. Sex sometimes possible, penis still not draining properly after erection.


Urology appointment (10 weeks): Again, no treatment. Told to observe for another 6 weeks and go in to be retested for stds.


STD specialist (12 weeks): Urethral discharge swabbed, put on a slide, and tested for all testable STD's. Results all came back negative but doctor said that they did find a lot of bacteria. Prescribed 1000mg Azithromiacin, one time dose. No effect.


General practice doc (14 weeks): Doctor suggests that symptoms may just be due to inflammation. Prescribed a one-week course of prednisone (started at 60mg, ended at 20mg). Still no effect.


HELP! Any ideas what this is and how to treat it?

Reply Flag this Discussion

1 Replies:

  • UPDATE: Went to the urologists at the university medical center. They suspected prostatitis and took some urine before and after a prostate massage. It was painful. Yet the cultures came back negative.Please, anybody? This is destroying my life and it needs to be figured out.
    mikey5559900 1 Replies Flag this Response
Thanks! A moderator will review your post and it will be live within the next 24 hours.